Skip to content

Graphorin API reference v0.15.1


Graphorin API reference / @graphorin/security / oauth

oauth ​

Outbound OAuth subsystem of @graphorin/security. Implements the OAuth 2.1 surface required by the MCP authorization spec (Authorization Code + PKCE-S256 with RFC 7636, Refresh Token grant + RFC 6749 § 6 rotation, Device Authorization Grant per RFC 8628, Dynamic Client Registration per RFC 7591, server + resource metadata discovery per RFC 8414 + RFC 9728, and the RFC 7009 token-revocation endpoint).

References ​

_getInflightRefreshKeysForTesting ​

Re-exports _getInflightRefreshKeysForTesting


_getOAuthAuditListenerCountForTesting ​

Re-exports _getOAuthAuditListenerCountForTesting


_resetInflightRefreshForTesting ​

Re-exports _resetInflightRefreshForTesting


_resetOAuthAuditListenersForTesting ​

Re-exports _resetOAuthAuditListenersForTesting


_resetOAuthLifecycleListenersForTesting ​

Re-exports _resetOAuthLifecycleListenersForTesting


_resetOAuthStrategiesForTesting ​

Re-exports _resetOAuthStrategiesForTesting


_setBrowserOpenerForTesting ​

Re-exports _setBrowserOpenerForTesting


_setDcrFetcherForTesting ​

Re-exports _setDcrFetcherForTesting


_setDeviceAuthFetcherForTesting ​

Re-exports _setDeviceAuthFetcherForTesting


_setDiscoveryFetcherForTesting ​

Re-exports _setDiscoveryFetcherForTesting


_setRevocationFetcherForTesting ​

Re-exports _setRevocationFetcherForTesting


_setTokenEndpointFetcherForTesting ​

Re-exports _setTokenEndpointFetcherForTesting


AuthorizationCodeFlowArgs ​

Re-exports AuthorizationCodeFlowArgs


AuthorizeCodeOptions ​

Re-exports AuthorizeCodeOptions


AuthorizeDeviceOptions ​

Re-exports AuthorizeDeviceOptions


base64Url ​

Re-exports base64Url


BrowserOpener ​

Re-exports BrowserOpener


buildOAuthSession ​

Re-exports buildOAuthSession


CallbackParams ​

Re-exports CallbackParams


computePkceChallenge ​

Re-exports computePkceChallenge


createInMemoryOAuthServerStore ​

Re-exports createInMemoryOAuthServerStore


createOAuthClient ​

Re-exports createOAuthClient


CreateOAuthClientOptions ​

Re-exports CreateOAuthClientOptions


DcrFetcher ​

Re-exports DcrFetcher


DeviceAuthFetcher ​

Re-exports DeviceAuthFetcher


DeviceAuthorizationFlowArgs ​

Re-exports DeviceAuthorizationFlowArgs


DeviceAuthorizationResponse ​

Re-exports DeviceAuthorizationResponse


DeviceUserCodeInfo ​

Re-exports DeviceUserCodeInfo


DiscoveredMetadata ​

Re-exports DiscoveredMetadata


discoverMetadata ​

Re-exports discoverMetadata


DiscoveryFetcher ​

Re-exports DiscoveryFetcher


DynamicClientRegistrationResult ​

Re-exports DynamicClientRegistrationResult


emitOAuthAudit ​

Re-exports emitOAuthAudit


emitOAuthLifecycle ​

Re-exports emitOAuthLifecycle


encodeBasicAuth ​

Re-exports encodeBasicAuth


fetchAuthorizationServerMetadata ​

Re-exports fetchAuthorizationServerMetadata


findOAuthStrategies ​

Re-exports findOAuthStrategies


generatePkceVerifier ​

Re-exports generatePkceVerifier


generateState ​

Re-exports generateState


getOAuthStatus ​

Re-exports getOAuthStatus


GraphorinOAuthError ​

Re-exports GraphorinOAuthError


listOAuthSessions ​

Re-exports listOAuthSessions


listOAuthStrategies ​

Re-exports listOAuthStrategies


LocalCallbackServer ​

Re-exports LocalCallbackServer


LocalCallbackServerOptions ​

Re-exports LocalCallbackServerOptions


loginInteractive ​

Re-exports loginInteractive


LoginInteractiveOptions ​

Re-exports LoginInteractiveOptions


LoginInteractiveResult ​

Re-exports LoginInteractiveResult


OAuthAuditAction ​

Re-exports OAuthAuditAction


OAuthAuditActor ​

Re-exports OAuthAuditActor


OAuthAuditDecision ​

Re-exports OAuthAuditDecision


OAuthAuditEvent ​

Re-exports OAuthAuditEvent


OAuthAuditListener ​

Re-exports OAuthAuditListener


OAuthAuthorizationError ​

Re-exports OAuthAuthorizationError


OAuthCallbackError ​

Re-exports OAuthCallbackError


OAuthCallbackPortError ​

Re-exports OAuthCallbackPortError


OAuthClient ​

Re-exports OAuthClient


OAuthDiscoveryError ​

Re-exports OAuthDiscoveryError


OAuthFlowAbortedError ​

Re-exports OAuthFlowAbortedError


OAuthLifecycleEvent ​

Re-exports OAuthLifecycleEvent


OAuthLifecycleEventName ​

Re-exports OAuthLifecycleEventName


OAuthLifecycleListener ​

Re-exports OAuthLifecycleListener


OAuthPeerDependencyMissingError ​

Re-exports OAuthPeerDependencyMissingError


OAuthRefreshError ​

Re-exports OAuthRefreshError


OAuthRegistration ​

Re-exports OAuthRegistration


OAuthRegistrationError ​

Re-exports OAuthRegistrationError


OAuthRegistrationUnsupportedError ​

Re-exports OAuthRegistrationUnsupportedError


OAuthRevokedError ​

Re-exports OAuthRevokedError


OAuthServerMetadata ​

Re-exports OAuthServerMetadata


OAuthSession ​

Re-exports OAuthSession


OAuthSessionMetadata ​

Re-exports OAuthSessionMetadata


OAuthStatusSnapshot ​

Re-exports OAuthStatusSnapshot


OAuthStrategy ​

Re-exports OAuthStrategy


onOAuthAudit ​

Re-exports onOAuthAudit


onOAuthLifecycle ​

Re-exports onOAuthLifecycle


openInBrowser ​

Re-exports openInBrowser


postToTokenEndpoint ​

Re-exports postToTokenEndpoint


ProtectedResourceMetadata ​

Re-exports ProtectedResourceMetadata


readOAuthErrorFields ​

Re-exports readOAuthErrorFields


refreshAccessToken ​

Re-exports refreshAccessToken


RefreshAccessTokenArgs ​

Re-exports RefreshAccessTokenArgs


RefreshFailureEvent ​

Re-exports RefreshFailureEvent


refreshOAuthSession ​

Re-exports refreshOAuthSession


registerDynamicClient ​

Re-exports registerDynamicClient


RegisterDynamicClientOptions ​

Re-exports RegisterDynamicClientOptions


registerOAuthStrategy ​

Re-exports registerOAuthStrategy


RevocationFetcher ​

Re-exports RevocationFetcher


revokeOAuthSession ​

Re-exports revokeOAuthSession


revokeOAuthToken ​

Re-exports revokeOAuthToken


RevokeOAuthTokenArgs ​

Re-exports RevokeOAuthTokenArgs


runAuthorizationCodeFlow ​

Re-exports runAuthorizationCodeFlow


runDeviceAuthorizationFlow ​

Re-exports runDeviceAuthorizationFlow


startLocalCallbackServer ​

Re-exports startLocalCallbackServer


TokenEndpointBody ​

Re-exports TokenEndpointBody


TokenEndpointFetcher ​

Re-exports TokenEndpointFetcher


TokenEndpointResponse ​

Re-exports TokenEndpointResponse


TokenRotationEvent ​

Re-exports TokenRotationEvent


tryProtectedResourceMetadata ​

Re-exports tryProtectedResourceMetadata